発生現象

各チャット通知設定においてChatworkに連携する設定を行ったが、
未読マークがつかない/未読通知バッジがつかない

 

原因

チャット通知設定に設定されているChatworkのアカウントが
ご自身が利用されているアカウントになっています。

Chatworkの仕様上、
「他のアカウント」→「ご自身のアカウント」への通知は正常に行われますが

「ご自身のアカウント」→「ご自身のアカウント」への通知は
未読マークとして表示されない仕様となっています。

 

対策

通知用のChatworkアカウントを別途新規作成(フリープランでも可)

または、

既存の別ChatworkアカウントにてUTAGE側で「チャット通知設定」で連携することで
ご自身のChatworkアカウントに正常に通知されるようになります。

 

設定例
ーーー
・Chatworkアカウント①(新規作成/またはお持ちの別Chatworkアカウント)
→ 通知用のトークルームを作成

・Chatworkアカウント②(現在あるご自身のChatworkアカウント)
→ ①で作成したトークルームに参加

・UTAGE側の通知設定へ設定するChatwork
→ Chatworkアカウント①

この設定をすることで、
①で作成したトークルームへ通知が届き、
②のご自身のアカウント側で未読通知を確認することができます。
ーーー

 

 

Comments are closed.