発生現象
UnivaPay決済を利用しているファネル決済ページ(決済フォーム)や
イベント・予約機能の決済ページ(申込フォーム)で、
「エラー/無効なトークン」を表示
原因
UnivaPay側のアプリトークンが
以下のいずれかの原因により無効化されています。
・UTAGEの決済連携設定に誤ったトークンあるいは
シークレットが貼り付けられている。
・UnivaPay側のアプリトークンが削除されている。
いずれのケースでも、UnivaPayのアプリトークンを再作成し、
UTAGEの決済連携設定で新規のトークンとシークレットに
差し替えることで当該事象が解消いたします。
対応方法
アプリトークンを新規作成する
UnivaPay新システム管理画面にログイン後、
アプリトークンの画面よりトークンとシークレットを取得します。
『本番モード』用と『テストモード』用のそれぞれで
アプリトークンの追加が必要です。
▼『本番モード』用のアプリトークンを取得する
1.UnivaPay管理画面にログインします。
https://merchant.univapay.com/login
2.左側メニュー「アプリトークン」を開き、「+新規作成」ボタンを押します。
3.「利用店舗を指定する」にチェックを入れ、UTAGEで利用予定の「店舗」名を選択します。
4.「モード」を【本番】に指定します。
5.「ドメイン」を指定します。【+追加】を押し、「utage-system.com」を入力します。
UTAGEの「独自ドメイン管理」に追加した独自ドメイン(サブドメイン形式)を利用する場合は、【+追加】ボタンより独自ドメインも指定します。
例えば、「https://sub.utage.com」というURLの場合、入力するドメインは「sub.utage.com」です。
6.上記の設定が完了したら「作成」ボタンを押します。
7.本番モードのトークン、シークレットが表示されますのでコピーします。
※シークレットは一度しか表示されませんので、メモ帳などに保存してください。
8. UTAGE画面より【ファネル】>【決済連携設定】>【UnivaPay(新システム)連携設定】の本番モードの【トークン、シークレット】の箇所に手順7で取得したトークン、シークレットを入力します。
9.本番モードのトークンとシークレットの入力が完了したら、UnivaPay新システム管理画面に戻り、【シークレットを保存しました。】ボタンを押します。
10.「シークレットを保存しましたか?」のポップアップが表示されますので「はい」をクリックします。
11.アプリトークン一覧に作成した本番モードのアプリトークンが表示されます。
本番モードの設定は以上です。続いてテストモードのアプリトークンを作成します。
▼『テストモード』用のアプリトークンを取得する
1.アプリトークン一覧より「新規追加」を押します。
2.「利用店舗を指定する」にチェックを入れ、「店舗」を指定します。
3.「モード」を【テスト】に指定します。
4.「ドメイン」を指定します。【+追加】を押し、「utage-system.com」を入力します。
UTAGEの機能で独自ドメインを利用する場合は【+追加】より独自ドメインも指定します。
例えば、「https://sub.utage.com/」というURLの場合、ドメインは「sub.utage.com」です。
5.上記の設定が完了したら「作成」ボタンを押します。
6.テストモードのトークン、シークレットが表示されますのでコピーします。
※シークレットは一度しか表示されませんので、メモ帳などに保存してください。
7.UTAGE画面より【ファネル】>【決済連携設定】>【UnivaPay(新システム)連携設定】のテストモードの【トークン、シークレット】の箇所に手順6で取得したトークン、シークレットを入力します。
8.テストモードのトークンとシークレットの入力が完了したら、UnivaPay新システム管理画面に戻り、【シークレットを保存しました。】ボタンを押します。
9.「シークレットを保存しましたか?」のポップアップが表示されますので「はい」をクリックします。
10.アプリトークン一覧に作成したテストモードのアプリトークンが表示されます。テストモードの設定は以上です。
UTAGE画面に戻り、【UnivaPay(新システム)連携設定】のすべての入力が完了したら【保存】ボタンを押してください。
検索用キーワード:ユニバペイ、ユニヴァペイ