発生現象

UnivaPay決済を利用しているファネル決済ページ(決済フォーム)や
イベント・予約機能の決済ページ(申込フォーム)で、
「エラー/アプリトークンのドメインが不正です」を表示

 

原因

UnivaPay側のアプリトークン作成時、ドメイン指定の箇所で
UTAGEで利用している独自ドメイン(サブドメイン形式)が指定されていない。

または会員サイトのカード情報変更手続きの場合、
会員サイトのドメイン(utage-system.comや独自ドメイン)が
アプリトークンに設定されていない。

※特に、決済ページでは「独自ドメイン(サブドメイン形式)」、
会員サイトは「UTAGEデフォルトドメイン(utage-system.com)」
を利用するケースで発生する事例が報告されています。

いずれのケースでも、UnivaPayのアプリトークンを再作成し、
・UTAGEデフォルトドメイン(utage-system.com)
・独自ドメイン管理に追加した独自ドメイン(サブドメイン形式)
を1つのアプリトークン内に両方同時指定することで現象が解消いたします。

 

対応方法

Step1:UnivaPay管理画面にログインし、アプリトークンを新規作成します。

UnivaPay管理画面 > アプリトークン > 【+新規作成】ボタン押下

 

Step2:ドメイン指定の箇所で「utage-system.com」とUTAGEの独自ドメイン管理に追加済みの「サブドメイン名」を両方同時指定します(追加するドメイン名が複数存在する場合は、全て漏れなく入力してください)
※例えば、UTAGE側「独自ドメイン管理」に「sub2.utagesample.com」を追加した場合、入力するドメインは「sub2.utagesample.com」です。

 

Step3:UnivaPay側でアプリトークン作成完了後、UTAGE側でアプリトークンの情報を差し替えます。
UTAGE > ファネル > 決済連携設定 > UnivaPay(新システム)連携設定

 

本番モードのアプリトークン差し替えが完了したら、
テストモードでもアプリトークンを再作成し、
UTAGE側「決済連携設定」に上書き保存してください。

 

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